Fetchreport Not Working

I press the send button and it does nothing. What should I do?


Are you using the PDF Creator or the web site?

My desktop Fetchreport is not responding, so I went to
the web site and uploaded the report from there.

At least that seems to still work.

I have already downloaded and repaired my original
Fetchreport… but that did no help it.

Do I need to uninstall and then install from scratch?

I have been having the same problem. It says it is uploading but goes no where.

I’m having the same problem!

Hey guys,

I’m going to be calling you each over today/tomorrow. I need to get in touch with one of our software developers first and set a few things up. I’ll post here later once we sort things out.


Called y’all with no answer. Please take a look at the e-mail I sent each of you. If anyone else is having the same problem, please e-mail me.

Hey guys,

I just talked to John and we figured out the problem. It’ll take me about 45 minutes to an hour to fix. I’ll post here when everything’s OK again.


OK. The problem is solved… you should be able to upload again. What happened:

FetchReport sends all data over SSL for high security, and the SSL certification for that server expired today. We’ve purchased a 10 year certificate (and I’ve set up reminders for 10 years in the future so that it doesn’t happen again).

Sorry about the mix-up. Everything should be working fine now. On another note, look for some new features to be added pretty soon.


Chris writes

OK. I’ll post here again in January of 2018. :cool:

Still not working.

Might be your Cookies John. Clean them out for fetch report.

Hey guys,

John and I figured it out earlier today (sorry–I didn’t get a chance to post until just now). It turns out that his Internet settings were interfering with the FetchReport PDF Creator’s connection to FetchReport.com.

Now I think that the SSL fix should have solved everyone else’s issues with FetchReport, but if it didn’t and you use Firefox as your browser, try this:

Open up Internet Explorer and see if you can connect to the Internet. FetchReport uses the same connection settings as MSIE, so if it can’t connect, neither can FetchReport (Firefox ignores these settings, so you might be able to browse the Web with it fine and still not be able to connect with FetchReport). If you CAN’T connect with Internet Explorer, try the following:

Open your Control Panel and go to Internet Options, then click on the Connections tab. In the connections tab, make sure the right connection is set as default. If you use broadband Internet, the “Never dial a connection” option should be checked. If this is set incorrectly, both FetchReport and Internet explorer will try to connect via the bad connection and fail.

If you’re still having trouble after fixing that, get in touch with me via e-mail.