HELP! HG stops when browsing for photos

HomeGauge 5: Working on a new report and Homeguage will stop working when I click the browse button to load photos.
Tried re-installing and also refreshing data base but still shuts down and loads a trouble reporting pop-up wanting to know what I was doing when it (HG) stopped working. Have also restarted PC and still has the problem

Any ideas, any one else experiencing this issue?

Can you see the photos on the device or memory card through windows?
Is this the desktop version of HG?


It is likely happening because in that picture folder is a video clip and your Quicktime plug in is out of date. Go to Apple, get quicktime and run it. Then install hg and it will see the quicktime and stitch it in and video and everything should work.

5.2 due out very soon will no longer rely on quicktime.

Thanks Dom for helping!

Actually I cant even get that far, It crashes as soon as I select (click) the Browse button. Also noticed that it will also crash when I click the “file” icon (to open a file) next to the photos button.
I do have all my files backed up to cloud. I’m going to try and uninstall and then fresh reinstall HG 5. (I’ll let you know if that works) And yes this is the desktop version, running windows 10.

Did you check to be sure you have latest version of Quicktime, as Russell suggested?

If it crashes when you click “Browse”, then it likely isn’t Quicktime.

Exactly, a reinstall of HG did not seam to fix it either. I am doing a work around by dragging the photos manually into the report, bypassing loading them into HG. I’ll give HG a call this morning to see what ideas they may have.

That’s the worst thing to happen when writing a report, trouble with software. :frowning:

Did you call in? Your comment above suggests you didn’t try removing the video, or quicktime as I suggested. Close HG and go to your folder with windows and remove the video…or, Download quicktime run and reinstall HG

I did call in yesterday (it was after hours the day it happened) and HG techs worked on the issue but have not yet figured it out. It is not a problem with video or QuickTime. Not a problem loading a video. it is a problem when opening the (when you click) the browse button in the photo pane. That is when it crashes
Still trying to figure it out. Suspect it might be related a recent program update such as iTunes or other apple product update that comes with it. (I use iTunes but no other apple products that I would need such as ipod updater and such)…I’m in the process of removing those things installed since just before the problem started.

So still trying to figure it out.

I have (I think) narrowed it down to having something to do with my router. We did change internet providers about 10 days ago. Did have to reset the router after that, and tracing back that is about the time. I thought it (problem) was connected to the new internet provider (or modem) but If I disconnect cable modem but still connected to the router. the problem is still there. Disconnect the router…and HG does not crash and I can load photos. I have been playing around with the router settings to see if I am able to pin down the problem. Also may just replace the router to see if that clears up the problem. Firmware of the router seams to have not changed, so I don’t think that is the problem (no new firmware either)…At least I’m getting somewhere.

Well not my router (in and of itself). My laptop, when hooked to the same wired connection does not have this problem working in HG, so it must be something specific to my desktop that is causing the crash. It does however look like I can temporarily disconnect from the router and internet to load the photos, in the photo pane.
I do have a theory that the last Windows update (came out about 3-23-16) may have something to do with this. searching the net, I have found others are having a problem with various programs and also not being able to access files.

For some reason windows will not give me the option to uninstall the latest update. Not sure why others have the uninstall option and this one doesn’t. (I’m not sure how to get rid of it manually)

It sounds like it works if you have no internet.

So it makes me think you have a virus in internet explorer that crashes when the internet is on.

I hate to tell people that because it sounds like we are trying to pass the buck.

I would suggest to turn off all plugins in IE.

I have tried with all plugins disabled and even with IE turned off and it still crashes. So still trying to figure out the problem. The temp disconnecting from router/internet to load pictures is the only solution found so far.

I am having the same issue with Windows 10 and Homegauge crashing when I click on the “Browse” button. Tried re-installing older versions of Homegauge but to no avail. Also this crashed even when my internet connection was disconnected.

Now I am wondering at 12:33 AM how I am going to get this report done.

I have found a temporary workaround for anyone having this problem. This workaround avoids the need to click on the “browse” button. Hopefully the issue will still be addressed.

  1. Using explorer, navigate to the HomeGauge folder where your reports, templates, and other settings are located
  2. Open the “settings.xml” file using an editor like notepad
  3. Find the line starting with <picDir>, and manually edit the path to the new path where the photos are.
  4. Save the changed “settings.xml” file

When you open HomeGauge, now you just click “load” to bring in your new photos to the report.

Thanks for that! My work around is to Temporarily unplug my Router. And then when I click “Browse” it will pop-up the files so I can choose. But I have to unplug “at the Router”. If I unplug at the modem, (physically disconnect the internet) it will still crash.
I think it is a HG file not playing nice with something in my desktop, since my laptop has no issues even if hard wired (Ethernet) to my router.

I am using HG 5.2 (and have for about a month) and this issue is still persistent with 5.2 as it was before with 5.1.

Jeffrey, Can I ask what internet service you are with and also what Modem? I am using a Belkin modem and an Arris modem with TDS (cable) as internet provider.

That was very smart Jeff! I will pass this on to the developer and see if he knows what’s going on.

Larry, I am using FIOS and the router they provided (not sure what brand), however my laptop is connected wirelessly to that router so I have to disable my WiFi. Since that didn’t work for me, I had to look for another way.

I noticed after the Windows 10 upgrade, my folder and drive permissions were reset. I think the problem with HomeGuage is that it is encountering a lack of permission where permission is expected, causing it to crash.